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1. Wichtige Hinweise

Die Software Qube 5 Editor V2 ist auf der LED-Qube 5 (V2) CD-ROM bzw. unter 
http://www.qube-solutions.de verfügbar.
Getestet wurde der Qube 5 Editor V2 unter dem Betriebssystemen Windows XP SP2, 
Windows Vista 32bit (x86) und Windows 7 32bit (x86).

Der Editor kann sowohl für die LED-Qube 5 als auch für den Nachfolger LED-Qube 5 
V2 verwendet werden.

Der Qube 5 Editor V2 besteht aus folgenden Dateien:

Qube5EditorV2.exe Ausführbare Anwendung
mingwm10.dll Für den Betrieb notwenige Library
qextserialportd.dll Für den Betrieb notwenige Library
QtCore4.dll Für den Betrieb notwenige Library
QtGui4.dll Für den Betrieb notwenige Library
QtOpenGL4.dll Für den Betrieb notwenige Library

Um die Software verwenden zu können, müssen sich diese Dateien in einem 
gemeinsamen Ordner befinden. Die Qube5EditorV2.exe ist das ausführbare 
Programm.

Hinweis: Wir haften nicht für die Beschädigung von Programmen, 
Dokumenten oder sonstigen Dateien, welche durch 
unsere Software entstehen.

Der Qube 5 Editor V2 ist unter der GNU GPL V3 Lizenz veröffentlicht. Er wurde mit dem 
mächtigen Cross-Platform Framework QT 4.5 in C++ programmiert und kann von 
jedermann weiterentwickelt werden. Der Quellcode steht auf auf unserer Homepage zum 
Download zu Verfügung.
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2. Allgemeines

2.1 Funktionsumfang

Im Qube Editor können eigene Animationen und Figuren erstellt werden, die anschließend 
auf die Qube übertragen werden können, und dort dauerhaft im Speicher abgelegt 
werden.

Der Editor bietet folgende Funktionalitäten:

➢ Verwaltung von bis zu 1000 Figuren (Einfügen, Klonen, Verschieben, Löschen von 
Figuren) 

➢ Setzen der Zustände für jede einzelne LED, bei jeder einzelnen Figur 
➢ Variable Anzeigezeiten für jede einzelne Figur einstellbar
➢ Ändern der Anzeigezeiten aller Figuren auf einmal
➢ 3D-Modell-Ansicht der Qube 5, drehbar in jede Richtung (OpenGL) 
➢ Zurücksetzen der 3D-Ansicht in eine definierte Ausgangslage
➢ Play-Mode zur Animationsvorschau innerhalb der Software
➢ Live-Mode zur sofortigen Anzeige von Figuren auf dem Kubus
➢ Selektieren und Löschen ganzer Ebenen (Reihen, Spalten, Ebenen) 
➢ Random-Funktion zum setzen zufälliger Zustände 
➢ Listenvorschau des erzeugten Figuren-Sets 
➢ Speichern und Laden ganzer Figuren-Sets 
➢ Anhängen von Teil-Sets zur schnelleren Erzeugung neuer Sets
➢ Tag- und Nacht-Modus
➢ Zoom-Funktion (vergrößern bzw. verkleinern der 3D-Ansicht)
➢ Multi-Select-Mode (setzen mehrerer LEDs auf einmal)
➢ Lock-Mode (verhindert das verdrehen des 3D-Modells beim setzen von LEDs)
➢ Einstellbare Farben für die Leuchtdioden und den Hintergrund
➢ Tastenkombinationen für den schnellen Aufruf der wichtigsten Funktionen
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2.2 Technik

Der Qube Editor V2 wurde in C++ programmiert unter der Verwendung von QT 4.5, einem 
mächtigen Cross-Platform Framework. Das Framework kann kostenlos heruntergeladen 
werden unter http://qt.nokia.com/downloads . (QT SDK for Windows)
Die Anwendung wurde unter Windows XP SP2 programmiert und getestet, sollte sich aber 
(Dank der Verwendung von QT) ohne große Probleme auch auf Linux oder MacOS-
Systeme portieren lassen. Wer vor hat dies zu tun, ist herzlich eingeladen uns über seine 
Erfahrungen dazu zu berichten.
Von Qube Solutions wird momentan nur eine Version für Windows-Systeme unterstützt.
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3. Übersicht der Schaltflächen

1. Menü & Toolbar
2. Vorschau
3. Liste &  Listenverwaltung
4. Bewegen & Drehen
5. Zustände
6. Auswahl
7. Statusbar
8. Verbindungsaufbau & Datenübertragung
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4. Beschreibung der Schaltflächen

Hier finden Sie die detailierte Beschreibung der unter Kapitel 3. Übersicht der
Schaltflächen vorgestellten Schaltflächen.

4.1 Menü & Toolbar

A) Speichern Speichert das aktuelle Figuren-Set der Liste in die aktuell 
angegebene Datei, ist keine Datei ausgewählt, wird der 
Speichern unter Dialog angezeigt.

B) Speichern unter Ruft den von Windows-Programmen bekannten Speichern 
unter Dialog auf. Es kann Speicherort und Name der Datei 
ausgewählt werden, in welche das aktuelle Figuren-Set 
gespeichert werden soll.

C) Öffnen Öffnet ein bereits abgespeichertes Figuren-Set, ebenfalls mit 
bekanntem Windows Dialog.
Vorsicht: Das aktuelle Figuren-Set in der Liste wird 
dadurch überschrieben!

D) Ansicht Verändert die Ansicht, welche im Vorschaufenster anzeigt und 
in der kleinen Vorschau der Liste angezeigt wird.
Standard (nicht aktiviert): Perspektivische Ansicht
Aktiviert: Orthogonale Ansicht

E) Koordinatenachsen Blendet die drei Koordinatenachsen ein oder aus
Standard (nicht aktiviert): Koordinatenachsen aus
Aktiviert: Koordinatenachsen an
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F) Tag- / Nacht-Modus Umschaltung zwischen Tag- und Nacht-Modus
Standard (nicht aktiviert): Tag-Modus
Aktiviert: Nacht-Modus

G) Rücksetzen Zurücksetzen der 3D-Ansicht der Qube 5 in die definierte 
Ausgangslage

H) Einstellungen Öffnet das Dialog-Fenster für die Farbeinstellungen
(Farbeinstellungen für LEDs und Hintergrund)
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New Erstellt ein neues, leeres Figuren-Set in der Schaltfläche 
Liste

Vorsicht: Das aktuelle Figuren-Set in der Liste wird 
dadurch überschrieben!

Open Selbe Funktionalität wie Öffnen in der Toolbar
Append Wie Open, mit dem Unterschied, dass das geöffnete 

Figuren-Set an das aktuell geöffnete Figuren-Set angehängt 
wird.

Save Selbe Funktionalität wie Speichern in der Toolbar
Save As Selbe Funktionalität wie Speichern unter in der Toolbar
Exit Schließt die gesamte Anwendung Qube 5 Editor

Vorsicht: Das aktuelle Figuren-Set wird gelöscht

Select All Setzt alle 125 LEDs der aktuell ausgewählten Figur
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Coordinates Selbe Funktionalität wie Koordinatenachsen in der Toolbar
Perspective Selbe Funktionalität wie Perspektive in der Toolbar
NightMode Selbe Funktionalität wie Tag- / Nacht-Modus in der Toolbar
Reset Rotation Selbe Funktionalität wie Rücksetzen in der Toolbar
Settings Selbe Funktionalität wie Einstellungen in der Toolbar
Save Layout Speichert die aktuelle Position der beweglichen 

Schaltflächen ab
Load Layout Lädt die mit Save Layout abgespeicherten Positionen der 

Schaltflächen

About Öffnet ein Dialogfenster mit allgemeinen Informationen zur 
Software Qube 5 Editor V2
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4.2 Vorschau

Die Vorschau zeigt die aktuell, in der Liste, ausgewählte Figur an. 

Bedienung:
Der virtuelle Kubus lässt sich in alle Richtungen drehen, wenn in den freien 
Vorschaubereich mit der linken Maustaste geklickt, die Taste gehalten und dann die Maus 
bewegt wird.
Durch klicken auf die einzelnen, virtuellen LEDs werden diese an- bzw. abgeschaltet.
Wird gleichzeitig die Taste „Shift“ auf der Tastatur und die linke Maustaste gehalten, so 
können gleich mehrere LEDs angeschaltet werden. Sind beide Tasten betätigt, dann 
werden die LEDs gesetzt, über die die Maus bewegt wird (Multi-Select-Mode).
Die selbe Vorgehensweise gilt für das Rücksetzen von LEDs. Allerdings muss hier „Shift“ 
und die rechte Maustaste betätigt werden.
Beim Drücken der Tasten „Shift“ oder „Alt“ wird ein verdrehen des 3D-Modells verhindert 
(Lock-Mode)

Durch drehen des Mausrades kann die gesamte, virtuelle Kubus größer oder kleiner 
dargestellt werden (Zoom-Funktion).
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4.3 Liste & Listenverwaltung

A) Nummer Gibt an, welche Nummer die Figur in der Liste hat. Die 
Nummern sind fortlaufend.

B) Vorschau Es wird eine verkleinerte Vorschau für die jeweilige Figur in 
der Liste angezeigt. Wird die Figur geändert, ändert sich auch 
die Vorschau in der Liste.

C) Name Es ist möglich jeder Figur einen Namen zu geben. Wenn kein 
Name vergeben wird, so geschieht dies automatisch.
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D) Anzeigezeit Ermöglicht die Anzeigedauer einer Figur zu verändern. Der 
Einstellbare Bereich liegt zwischen 1 und 20.
1 → sehr schnell (44Hz)
10 → standard (4,4Hz)
20 → sehr langsam (0,9Hz)

C) Play Die in der Liste enthaltenen Figuren werden auf dem virtuellen 
Kubus abgespielt. Während dem Ablauf der Figuren und 
Animationen kann der Kubus gedreht und die Zoom-Funktion 
genutzt werden.

C) Change Times Öffnet ein Dialog-Fenster für die Anzeigezeit. Hier können die 
Anzeigezeiten für alle in der Liste enthaltenen Figuren auf 
einmal verändert werden.

Move Up Bewegt die aktuell ausgewählte Figur um eine Position nach 
oben

Clone Erzeugt eine Kopie der aktuell ausgewählten Figur und 
platziert den "Klon" genau hinter dieser Figur

Move Down Bewegt die aktuell ausgewählte Figur um eine Position nach 
unten

Add Fügt am Ende der Liste eine leere Figur ein

Hinweis: Im Vorschaufenster wird noch die zuletzt 
markierte Figur angezeigt und diese kann verändert 
werden. So lassen sich schnell und einfach Abläufe 
erzeugen.

Insert Selbe Funktionalität wie Add, mit dem Unterschied, dass die 
Figur direkt nach der aktuell markierten Figur eingefügt wird.

Del Löscht die aktuell markierte Figur aus der Liste. Es ist auch 
möglich mehrere Figuren gleichzeitig zu markieren und 
diese zu löschen.
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4.4 Bewegen & Drehen

Wird ein Teil einer Figur oder die ganze Figur aus dem darstellbaren Bereich 
geschoben, gehen die ausgeschobenen Zustände verloren!

Um einfacher arbeiten zu können empfehlen wir die Koordinatenachsen zu aktivieren.
Die Pfeilspitze der Koordinatenachsen zeigt in die positive (+) Richtung!

X- Verschiebt die aktuell markierte Figur um eine Zeile in 
negativer X-Richtung

X+ Verschiebt die aktuell markierte Figur um eine Zeile in 
positiver X-Richtung

Y- Verschiebt die aktuell markierte Figur um eine Ebene in 
negativer Y-Richtung

Y+ Verschiebt die aktuell markierte Figur um eine Ebene in 
negativer Y-Richtung

Z- Verschiebt die aktuell markierte Figur um eine Reihe in 
negativer Z-Richtung

Z+ Verschiebt die aktuell markierte Figur um eine Reihe in 
positiver Z-Richtung
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X- Dreht die aktuell markierte Figur um die X-Achse in negativer 
Richtung (um 45°)

X+ Dreht die aktuell markierte Figur um die X-Achse in positiver 
Richtung (um 45°)

Y- Dreht die aktuell markierte Figur um die Y-Achse in negativer 
Richtung (um 45°)

Y+ Dreht die aktuell markierte Figur um die Y-Achse in positiver 
Richtung (um 45°)

Z- Dreht die aktuell markierte Figur um die Z-Achse in negativer 
Richtung (um 45°)

Z+ Dreht die aktuell markierte Figur um die Z-Achse in positiver 
Richtung (um 45°)
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4.5 Zustände

Die vier Befehle haben jeweils Auswirkung auf alle 125 LEDs und wirken sich auf die 
aktuell in der Liste markierte Figur aus.

SetAll Setzt alle LEDs
UnsetAll Setzt alle LEDs zurück
Random Erzeugen eines Zufallsmusters
Invert Erzeugen der invertierten Figur
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4.6 Auswahl

Mit den drei Schiebereglern (A) lassen sich ganze Levels (Ebenen), Rows (Reihen) oder 
Cols (Zeilen) auswählen und dann setzen oder rücksetzen.
Um die Schieberegler zu aktivieren muss die jeweilige Kontrollbox (B) markiert werden. In 
der Schaltfläche Vorschau wird der momentan ausgewählte Bereich durch eine 
Farbmarkierung hervorgehoben.
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4.7 Statusbar

In der Statusbar werden verschiedene Statusmeldungen zur Information für den Benutzer 
angezeigt.
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4.8 Verbindungsaufbau & Datenübertragung

Mit den hier behandelten Schaltflächen lässt sich die Verbindung mit der LED-Qube 5 
aufbauen, der Live-Mode aktivieren und Figuren-Sets übertragen.

Als Erstes muss geklärt werden, an welchem COM-Port die LED-Qube 5 angeschlossen 
ist. Falls Ihnen die Nummer dieses COM-Ports nicht bekannt sein sollte, folgen Sie 
bitte den Anweisungen in der Inbetriebnahmeanleitung.

Der COM-Port darf maximal die Nr. 10 sein, also COM10. Ist der COM-Port auf einer 
höheren Nummer, so kann mit dem Qube 5 Editor V2 nicht auf die Qube 5 
zugegriffen werden!

In der Drop-Down-Liste Com-Port sind alle verfügbaren Ports aufgelistet. Wählen Sie den 
den Port mit der LED-Qube 5 aus.

Connect / Disconnect Stellt die Verbindung zur LED-Qube 5 her / Trennt die 
Verbindung zur LED-Qube 5

Live-Mode Aktiviert den Live-Mode / Deaktiviert den Live-Mode

Das Abspielen der gespeicherten Figuren auf der Qube wird 
unterbrochen. Auf der Qube wird nun Live das selbe Bild wie 
in der Vorschau angezeigt. Dies ermöglicht das einfache 
Testen neuer Figuren.

Hinweis: Während der Live-Mode aktiviert ist können 
keine Figuren in den Speicher der LED-Qube 5 
programmiert werden. Nach dem Verlassen des Live-
Mode kann wieder programmiert werden.

Programm! Die aktuell in der Liste eingetragenen Figuren werden in den 
Speicher der Qube übertragen. Nach der Datenübertragung 
kann die Qube vom PC getrennt werden.
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http://www.qube-solutions.de/


                                            
                                                    

                                         Bedienungsanleitung: LED-Qube 5 (V2)

4.8 Tastenkombinationen (Shortcuts)

Mit Hilfe von Shortcuts kann schneller und komfortabler mit dem Qube 5 Editor V2 
gearbeitet werden.

Shortcut Funktion Beschreibung

STRG+N File File->New Neue Animation erstellen

STRG+O File->Open Animation öffnen

STRG+A File->Append Animation anhängen

STRG+S File->Save Animation speichern

SHIFT+S File->Save As Animation speichern als

STRG+SHIFT+A Edit->Select All Alle Figuren markieren

P View->Perspective Perspektive umschalten: 
Orthogonal / Perspektivisch

C View->Coordinates Koordinatensystem ein- / 
ausschalten

N View->NightMode Nachtmodus ein/ausschalten

Pos1 View->Reset Rotation Rücksetzen von Rotation und 
Zoom

STRG+E View->Settings Einstellungen für die Darstellung 
ändern

ALT+Pfeil-hoch Move Up Figur nach oben schieben

ALT+Pfeil-runter Move Down Figur nach unten schieben

ALT+C Clone Figur klonen

ALT+A Add Figur am Ende der Liste 
hinzufügen

ALT+I Insert Figur am Ende der Liste 
hinzufügen

ALT+D Delete Markierte Figur(en) löschen
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5. Bedienung der Software

Kapitel 3 und 4 geben eine Übersicht über die Schaltflächen des Qube 5 Editors V2. Die 
konkrete Bedienung und Vorgehensweise zur Erstellung von Figuren wird in den Videos 
dargestellt, welche auf unserer Homepage zum Download bereitstehen.
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